Symbols are not getting added and previous symbols got deleted

Discuss, post questions here about MTIBBridge the MetaTrader-Interactive Brokers trade-copier

Users who just registered, please write an email to
forum@trade-commander.de
with your username mentioned.
So we can distinguish you from bots.
Thank you
Post Reply
sudha0007
Posts: 11
Joined: Wed Jan 12, 2022 5:23 am

Symbols are not getting added and previous symbols got deleted

Post by sudha0007 »

why all my previous symbols are got deleted. Again while i am trying to add the selected symbols, its also not getting added. Please help. find the log screen shot.while trying to report from software itself, its also getting failed. hence i am writing to you.

board_admin
Site Admin
Posts: 241
Joined: Mon Apr 24, 2017 3:24 pm

Re: Symbols are not getting added and previous symbols got deleted

Post by board_admin »

Hello,
have you followed steps described in this short video ?
https://youtu.be/aRdi22OSpdo?list=PLYD3 ... dcECuxa954


If video is no help, perhaps something messed up. Please try the following:
1. In the copier menu/debug click on
Open configuration folder
2. In configuration folder open subfolder
API
3. In Folder API backup
contract.db
4. Close copier
5. Delete contract.db
6. Start copier do fresh symbol mapping

sudha0007
Posts: 11
Joined: Wed Jan 12, 2022 5:23 am

Re: Symbols are not getting added and previous symbols got deleted

Post by sudha0007 »

Followed the videos carefully. But still now working. Let me try with your 2nd suggestion. Can i upload
the video file here?

sudha0007
Posts: 11
Joined: Wed Jan 12, 2022 5:23 am

Re: Symbols are not getting added and previous symbols got deleted

Post by sudha0007 »

I have followed all the steps. Still not working. please help.

sudha0007
Posts: 11
Joined: Wed Jan 12, 2022 5:23 am

Re: Symbols are not getting added and previous symbols got deleted

Post by sudha0007 »

The system is allowing to add the instruments of contracts of future expiry period, but not allowing
to add the contracts for the today's expiry. System should allow the contracts of today's expiry also to be
added. Please rectify the system or guide, if any system settings to be done.

board_admin
Site Admin
Posts: 241
Joined: Mon Apr 24, 2017 3:24 pm

Re: Symbols are not getting added and previous symbols got deleted

Post by board_admin »

Please provide an example contract which is not working.
type,symbol, currency, expiry, conid

so we can test

sudha0007
Posts: 11
Joined: Wed Jan 12, 2022 5:23 am

Re: Symbols are not getting added and previous symbols got deleted

Post by sudha0007 »

symbol : BANKNIFTY2211338500CE
TYPE: OPT
currency: INR
expiry: JAN 13, 2022
exchange: NSE
conid: 526172161

Please check it early, otherwise symbol will be expired today. I had emailed you the video
proof also to your email id contact@trade-commander.de also.

board_admin
Site Admin
Posts: 241
Joined: Mon Apr 24, 2017 3:24 pm

Re: Symbols are not getting added and previous symbols got deleted

Post by board_admin »

Hello,
i checked the contract, may be too late.
It is correct, you can't add a contract that expires today.

I changed this and tested on your contract and got the messages not tradeable.
Please mind screenshots showing this.

An update, that allows 24 h expired contracts, can be downloaded from here:
https://drive.google.com/open?id=1-LIxQ ... p=drive_fs

Close copier before running setup please.
Attachments
logpage.png
logpage.png (55.69 KiB) Viewed 6557 times
contract.png
contract.png (28.19 KiB) Viewed 6557 times

sudha0007
Posts: 11
Joined: Wed Jan 12, 2022 5:23 am

Re: Symbols are not getting added and previous symbols got deleted

Post by sudha0007 »

Thanks for giving the updated version. It can be tested on the expiry date only. The next expiry date will be on 20/01/2022.
If any issue will come, i will intimate, but please look at into the issue on time, so that the symbol will not be removed out from TWS. thanks.

Post Reply