Search found 233 matches

by board_admin
Thu Jan 20, 2022 3:38 pm
Forum: MetaTrader-InteractiveBrokers Order Copier
Topic: same symbol database in two MTIB order copier
Replies: 1
Views: 5

Re: same symbol database in two MTIB order copier

# on source machine In the copier menu, go on Debug / Open Configuration Folder Then go to subfolder api. Copy file contract.db # on target machine In the copier menu go on Debug / Open Configuration Folder Then go to subfolder api. Close the copier rename or delete current contract.db Copy contract...
by board_admin
Wed Jan 19, 2022 11:06 pm
Forum: IBPlugin
Topic: Location of SW download and TS support files
Replies: 1
Views: 7

Re: Location of SW download and TS support files

Hello, please watch this video, that explains all. Some minutes. // this video explains the Admin Tool. You can reach help from admin tool and apply license using Admin Tool https://youtu.be/anCcZpmr_kQ?list=PLYD3H3VGco2AepOKwGwoP_QdcECuxa954 There are 4 videos explaining IBPlugin: #1 Installation #...
by board_admin
Wed Jan 19, 2022 8:31 pm
Forum: IBPlugin
Topic: Running TS Script on 2 Seprate Charts Simultaneously
Replies: 3
Views: 51

Re: Running TS Script on 2 Seprate Charts Simultaneously

Are you sure your EL condition was fullfilled? There is no information about the order_attribute_str. The funciton works, if it is called at all and your parameters are correct, your permissions fine, no margin problems etc. There is no reason why the function should not work, just because called in...
by board_admin
Sat Jan 15, 2022 12:35 am
Forum: MetaTrader-InteractiveBrokers Order Copier
Topic: MetaTrader Symbol(s) getting removed when stop and start
Replies: 4
Views: 40

Re: MetaTrader Symbol(s) getting removed when stop and start

Please open TeamViewer from help menu of copier. Provide id and pw.
Will have a quick look onto machine. Thank you
by board_admin
Fri Jan 14, 2022 6:37 pm
Forum: MetaTrader-InteractiveBrokers Order Copier
Topic: MetaTrader Symbol(s) getting removed when stop and start
Replies: 4
Views: 40

Re: MetaTrader Symbol(s) getting removed when stop and start

No, this should not be case and i can't reproduce this.


Please describe the procdure adding MT symbol and setting multiplier.
There is always a default multiplier but yours is empty.
by board_admin
Thu Jan 13, 2022 8:43 pm
Forum: MetaTrader-InteractiveBrokers Order Copier
Topic: Symbols are not getting added and previous symbols got deleted
Replies: 8
Views: 64

Re: Symbols are not getting added and previous symbols got deleted

Hello, i checked the contract, may be too late. It is correct, you can't add a contract that expires today. I changed this and tested on your contract and got the messages not tradeable. Please mind screenshots showing this. An update, that allows 24 h expired contracts, can be downloaded from here:...
by board_admin
Thu Jan 13, 2022 3:06 pm
Forum: MetaTrader-InteractiveBrokers Order Copier
Topic: Symbols are not getting added and previous symbols got deleted
Replies: 8
Views: 64

Re: Symbols are not getting added and previous symbols got deleted

Please provide an example contract which is not working.
type,symbol, currency, expiry, conid

so we can test
by board_admin
Thu Jan 13, 2022 5:30 am
Forum: MetaTrader-InteractiveBrokers Order Copier
Topic: Symbols are not getting added and previous symbols got deleted
Replies: 8
Views: 64

Re: Symbols are not getting added and previous symbols got deleted

Hello, have you followed steps described in this short video ? https://youtu.be/aRdi22OSpdo?list=PLYD3H3VGco2AepOKwGwoP_QdcECuxa954 If video is no help, perhaps something messed up. Please try the following: 1. In the copier menu/debug click on Open configuration folder 2. In configuration folder op...
by board_admin
Mon Jan 10, 2022 4:36 pm
Forum: IBPlugin
Topic: Running TS Script on 2 Seprate Charts Simultaneously
Replies: 3
Views: 51

Re: Running TS Script on 2 Seprate Charts Simultaneously

You should be able to attach your scripts to multiple charts.
In each script call connect with same parameters -> IP and port.

connect does nothing when you already connected (e.g. because another signal already did)
by board_admin
Fri Jan 07, 2022 3:30 pm
Forum: IBPlugin
Topic: Issues Connecting via Paper Account
Replies: 2
Views: 47

Re: Issues Connecting via Paper Account

Good. Just a comment:

The Admin Tool has 2 main purposes, creating Symbol Mapping Tables (Configurations)
and to maintain license.

So usually no need to run the Admin Tool, because it takes one lock from license.
by board_admin
Thu Dec 02, 2021 3:22 pm
Forum: IBPlugin
Topic: What's the root cause of this failure of placing order
Replies: 9
Views: 384

Re: What's the root cause of this failure of placing order

The error is related to license issue.
Do you have a 2n instance of IBPlugin running ?

What is the order log i pointed to telling ?
by board_admin
Wed Dec 01, 2021 4:45 pm
Forum: IBPlugin
Topic: What's the root cause of this failure of placing order
Replies: 9
Views: 384

Re: What's the root cause of this failure of placing order

Please have a look into your TWS account window.
How many accounts do you can see ?
by board_admin
Wed Dec 01, 2021 12:42 pm
Forum: IBPlugin
Topic: What's the root cause of this failure of placing order
Replies: 9
Views: 384

Re: What's the root cause of this failure of placing order

It is not about expiry, it is about # of IBKR accounts covered by license. Such error is not in the license log. Check the order log: C:\trade-commander.com\ibplugin\configurations\<your_config>\log\api\connection_1\channel_order.log <your_config> is the configuration used when init. Usually "defaul...
by board_admin
Tue Nov 30, 2021 8:27 pm
Forum: IBPlugin
Topic: What's the root cause of this failure of placing order
Replies: 9
Views: 384

Re: What's the root cause of this failure of placing order

the plugin installs a help file where you find all functions documented. For send order function return values, go to this table please: C:/Program%20Files/trade-commander.com/IBPlugin/documentation/tbl_general_error_codes.html Error code -2147483646 points to a license fault. All accounts visible i...
by board_admin
Mon Nov 08, 2021 3:00 pm
Forum: IBPlugin
Topic: Requesting a simple Easy Language/Strategy example using IBPlugin
Replies: 3
Views: 221

Re: Requesting a simple Easy Language/Strategy example using IBPlugin

First of all, there is no BUY statement... : There is, please look a bit closer: order_attribute_str="#1=1#53=BUY#6=MKT#49="; The order is defined by an attribute string. The possible attributes are listed in the help. If I attach that strategy/script to a chart it will just buy a market order Yes....
by board_admin
Sat Nov 06, 2021 1:44 pm
Forum: IBPlugin
Topic: Requesting a simple Easy Language/Strategy example using IBPlugin
Replies: 3
Views: 221

Re: Requesting a simple Easy Language/Strategy example using IBPlugin

The sample that is installed along with IBPlugin and be tested on MultiCharts should run perfectly without any problems also on TS. This sample is discussed in this video: https://youtu.be/lH3GE_pDm48?list=PLYD3H3VGco2AepOKwGwoP_QdcECuxa954 The example demonstrates the most important features. Pleas...
by board_admin
Fri Oct 29, 2021 1:27 pm
Forum: IBPlugin
Topic: What am I doing wrong here?
Replies: 6
Views: 9730

Re: What am I doing wrong here?

So I've been experimenting around with it and I've found that when I change the symbol to EURUSD, with the CONID you use in the demo, the orders go through, but they fire off repeated orders every second. Within a minute I had about thirty buy orders filled. Obviously it's a Demo account so no big ...
by board_admin
Fri Oct 29, 2021 1:19 pm
Forum: IBPlugin
Topic: What am I doing wrong here?
Replies: 6
Views: 9730

Re: What am I doing wrong here?

Hello Sir, when you call a Plugin function, it is executed once. So, if a function is fired multiple times, check your script code. When the EUR.USD symbol works, but yours not, then your symbol is not mapped. In this case, use the Admin Panel to map the symbol for your configuration (which is most ...
by board_admin
Tue Oct 26, 2021 4:30 pm
Forum: IBPlugin
Topic: What am I doing wrong here?
Replies: 6
Views: 9730

Re: What am I doing wrong here?

I checked out your code. I am not so familar with EasyLanguage, but it seems that the CONNECT part has called with each tick, which should not be a problem but causes unnecessary load. Just call Connect and the conid mapping once. The Plugin will keep connection. Find attached corrected script. Make...
by board_admin
Tue Oct 26, 2021 1:18 pm
Forum: IBPlugin
Topic: What am I doing wrong here?
Replies: 6
Views: 9730

Re: What am I doing wrong here?

Where does it crash ?
What TradeStation version. Is it 64 bit TS or 32 bit TS ?
Thank you